影子是一个会撒谎的精灵,它在虚空中流浪和等待被发现之间;在存在与不存在之间....

您现在的位置是:主页 > 工作记 >

易语言教学代码_日志输出进度条


  • 进度条.png

    .版本 2
    .支持库 EThread
    .支持库 iext2
    .程序集 窗口程序集_启动窗口
    .程序集变量 句柄
    .子程序 _按钮1_被单击
    .如果真 (线程_取状态 (句柄) = 1)
        线程_销毁 (句柄)
    .如果真结束
    启动线程 (&进度2, , 句柄)
    .子程序 进度
    .局部变量 x, 整数型
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “正在载入”)
    延时 (500)
    .计次循环首 (10, x)
        外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “.”)
        延时 (500)
    .计次循环尾 ()
    延时 (500)
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “载入完毕”)
    .子程序 进度2
    .局部变量 j, 整数型
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “正在载入”)
    超级编辑框1.内容 = “”
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “当前执行进度中……” + #换行符 + #换行符)
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “进度中:” + 取重复文本 (10, “□”) + “ 0%”)
    延时 (500)
    .计次循环首 (10, j)
        ' 外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “.”)
        超级编辑框1.内容 = 子文本替换 (超级编辑框1.内容, “□”, “■”, j, 1, 真)
        超级编辑框1.内容 = 子文本替换 (超级编辑框1.内容, 到文本 ((j - 1) × 10) + “%”, 到文本 (j × 10) + “%”, j, 1, 真)
        延时 (500)
    .计次循环尾 ()
    延时 (500)
    外部编辑框_加入文本 (超级编辑框1.取窗口句柄 (), “...载入完毕”)

    效果图


  • 上一篇:批处理如何运行adb shell以后的命令

    下一篇:没有了